ispmanager 6

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Panel authorization failure

Panel authorization failure

Symptoms

After entering the login and password and clicking the “Login” button, the authorization page is refreshed, but the login to the ispmanager panel web interface is not performed. 

Causes

  • Insufficient free space on the server disk or no free inodes;
  • panel cache files are corrupted;
  • authorization is performed via HTTP protocol without encryption;
  • end-to-end authorization by key via API is used with IP-address restriction enabled.

Solution

Insufficient free space on the server disk

  1. Connect to the server via SSH;
  2. Enter the df -h command to check the amount of free disk space, paying attention to the fullness of the root partition (the / symbol in the “Mounted on” column);
  3. Enter the df -ih command to check the number of free inodes on the disk, paying attention to the fullness of the root partition (the / symbol in the “Mounted on” column).

Free disk space can be increased by deleting large or by increasing the total disk capacity.

In the case of inodes, increasing the disk capacity will not increase their total number, since the number is set when the file system is installed. Each inode is linked to a single file, so it is most efficient to delete multiple small files, such as old log files or temporary files.

Corrupted panel cache files

To determine if the panel cache files are corrupted, connect to the server via SSH and run the following command:

cat /usr/local/mgr5/var/ispmgr.log | grep "Object:'parse_file'"

We do not recommend clearing the panel cache by yourself. Please contact the ispmanager technical support team to investigate the problem.

Authorization via HTTP

Correct work in the ispmanager 6 panel is only possible via HTTPS protocol.

To ensure proper authorization, add the https:// value (or replace it if the value  http:// is already present) before the panel address in the browser address bar.

To ensure automatic redirection to HTTPS upon logging into the panel, navigate to the "Panel Settings" - "Panel Address" - "Edit" menu section and enable the “Deny HTTP connections” option.

IP address restriction

In case the IP address restriction enabled in the user settings is triggered, the key authorization will not display a notification that connection from the current IP address is prohibited. 

To solve this issue, add the current IP address of the user to the list of allowed IP addresses or authorize from a previously set IP address.