ispmanager 6

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Issues activating ispmanager 6 panel

Issues activating ispmanager 6 panel

Symptoms

When activating a license, the following error occurs "No license available for your server. Perhaps, the activation key has been already used or has expired. Perhaps, the installed version of the product was released later than the one to which the specified key allows updating."

Causes

  • Attempting to activate the ISPmanager 5 panel with an ispmanager 6 license
  • No access to a server via port 1500
  • License information on the server is not updated yet
  • Server time does not match server time zone
  • IP address does not match the one specified in the license
  • No access to the licensing server from the server with the panel
  • The server is behind NAT and was not available during synchronization
  • Access to the panel's web interface is provided via a uncommon port

Solution

Activation of the panel with a correct license

The ispmanager 6 panel can only be activated with one of the following licenses: ispmanager 6 lite, pro, host or business. The ISPmanager 5 license is not suitable for activating the ispmanager 6 panel.

Panel update

Update the panel to the latest version according to the official documentation.

License information update

The license information is updated automatically every few hours. However, if it is necessary to update the information immediately, go to the "License Management" section and click the "Update License Information" link.

An alternative option is to start synchronization manually using the command:

/usr/local/mgr5/sbin/licctl fetch ispmgr

License information check

Make sure that the public IP address of your server is specified in the license settings in your personal account.

If the panel was activated using a key, generate a new key in your personal account and enter it in the “License Management” - “Activate License” section of the panel.

License server availability check

The licensing server has several IP addresses, as well as scripts for checking the license on these addresses.

For the licensing module to work correctly, access to the server via ports 80, 443 and 1500 is required. These ports must be open for incoming and outgoing connections to the licensing server at https://86.license5.ispsystem.com/.

To check availability of the licensing server, execute the following command:

  1. Make sure there is an up-to-date version of cURL installed on the server.
  2. Execute requests to the following addresses using cURL:
curl -i -k -L -v https://86.license5.ispsystem.com/pricelist/soft
curl -i -v http://212.109.222.131/mgr5.45.state  
curl -i -v http://212.109.222.143/mgr5.45.state  
curl -i -v http://144.76.174.134/mgr5.45.state  
curl -i -k -L -v https://212.109.222.131/mgr5.45.state
curl -i -k -L -v https://212.109.222.143/mgr5.45.state  
curl -i -k -L -v https://144.76.174.134/mgr5.45.state 

A correct response to a request will contain the HTTP/1.0 200 OK line, which will mean the server is available.

If a request to any of the specified URLs fails, it will be necessary to verify and adjust the relevant network settings. We recommend you to contact your server's system administrator or your hosting provider's support team in case you use their services.

Server time consistency check

Make sure the server time matches the current server time zone:

  • Check the exact time on any available server on the Internet and set the correct value
  • Synchronize the server time with the exact time servers (recommended)

Error search in the licensing module log

The licensing module log provides a clear record of any errors, enabling swift identification of the root cause of activation issues.

Information about obtaining a license is stored in a log file /usr/local/mgr5/var/licctl.log:

  • Error "TRIAL_AFTER_COMMERCIAL" indicates that the trial license activation is not possible after activation of the commercial license. To continue using the panel, you will need to purchase a commercial license.
  • Error "TRIAL_ALREADY_USED" indicates that it was not possible to activate a trial license after activation of another trial license (is also applicable after reinstallation of the OS, a trial license cannot be reactivated on a server with the same IP). To continue using the panel, you will need to purchase a commercial license.
  • Error "BADKEY" indicates that the key is incorrect, usually occurs after reinstalling the OS and panel. Try generating a new key.
  • Error "EXPIRED" indicates that the license has expired. Are are required to renew the licence and then attempt to activate it again.
  • Error "Got bad result from" indicates that a response was not received from the license server. In such case, an attempt will be made to make a request to another license server. If all license servers are unavailable, activation is not possible. We recommend to follow the instructions above regarding the checking of license server availability.
  • Error "BADTIME" indicates that the difference between the current time on the server and the time on the license server is more than one hour.
  • Error "NOIPV6" indicates that there was an attempt to obtain an ispmanager license from an IPv6 address.
  • Error "MYSQL FAILED" indicates that the remote MySQL server did not respond to the request and there will be an attempt to contact another server.
  • Error "BADINFO" indicates that an invalid request was sent from the panel's server.
  • Error "BACK QUERY FAILED" indicates that the license was found on the licensing server, however, the file could not be uploaded to the panel's server.

If the log contains the message "Good result from", this indicates that the response from the license server was successfully received. Similarly, the message "Got license with id" signifies that the license information was successfully received.