Error "Failed to fork" in ispmanager 6
Symptoms
The ispmanager panel web interface freezes, the main functions of the panel do not work, e.g. the installation of components or creation of backups.
The error "Failed to fork" is registered in the panel log or in the backup log.
PLEASE NOTE!
To find errors in both logs, use the following command :
grep -ai "Failed to fork" /usr/local/mgr5/var/ispmgr.log /usr/local/mgr5/var/backup2.log
Causes
The error message indicates a limitation of the operating system:
- The system has reached its limit on the number of processes;
- The user has reached the limit on the number of processes;
- Insufficient RAM.
Solution
It is necessary to check the system settings and assess the status of its resources:
- Analyze which processes consume the most RAM and optimize its usage;
- Increase the amount of RAM and/or swap file;
- Check the system and user limits for the number of processes, increase these parameters using the utilities "sysctl" and "ulimit"; the main system parameters that limit the number of processes are
threads-max
andpid_max
.