Errors when converting to CloudLinux
Symptoms
System conversion to CloudLinux via the ispmanager 6 module failed.
Causes
- License registration error
- CloudLinux servers are unavailable
- Cluster node is unavailable
- A critical error occurred during the OS conversion process
Solution
License registration error
The error occurs if the CloudLinux billing system was unable to register the license with the specified license key.
Make sure that the correct license key is specified.
CloudLinux servers are unavailable
In this situation, make sure that CloudLinux servers are accessible from the panel server.
PLEASE NOTE!
As of 08/30/2024, CloudLinux officially does not provide services for Russian accounts and Russian IP addresses.
Cluster node is unavailable
Make sure that cluster nodes in ispmanager 6 business are accessible.
Also, such a warning may be displayed during the conversion process as this is a correct behavior.
Critical error occurred during the OS conversion process
Such warnings are typically related to the cldeploy conversion script errors.
More information about this error can be found in the script log at /var/log/cldeploy.log
.
Examples
UEFI use
The “WARNING! Your /etc/fstab configuration is not explicit about device mounting on boot/efi.” warning registered in the script log signifies that using the UEFI subsystem for the boot partition may lead to conversion errors.
To modify the partition, refer to the official solution from CloudLinux.
Kernel issues
If necessary packages or dependencies for Kernel are missing, the script log will display errors of the format “kernel-3.10.0-962.3.2.lve1.5.85.el7.x86_64 has missing requires of <package_name>”.
If an improper version of the Kernel is used, the “cagefsctl error: 'Error: current running kernel is NOT supported” error will be registered in the log at /usr/local/mgr5/var/ispmgr.log
.
To resolve OS to CloudLinux conversion issues, please contact CloudLinux support!